Performanceproblem VMWare / Windows 7 / KDE (openSUSE 13.2) gelöst

Das Windows, das bei meinem Rechner dabei war, betreibe ich unter VMWare. Der Rechner selbst läuft unter Linux.

Leider hatte ich ziemliche Performance-Probleme beim Wechsel zwischen der VM und den anderen laufenden Programmen. Alleine auf einen anderen virtuellen Desktop zu wechseln, auf dem nur ein einziges Programm lief, hat gefühlt ewig gedauert und das System komplett lahm gelegt.

An sich fühlte sich das an, als würde das komplette RAM Inhalt auf die Festplatte ausgelagert. Wobei das eigentlich kaum möglich ist. Der Rechner hat 8 GB und die VM nur 4 GB. Da sollte eigentlich Luft sein. Von daher war mir immer schleierhaft, warum das so ein Problem ist. Zumal ich mir auch sicher bin, dass früher™ das Problem nicht so extrem in dieser Form bestanden hat.

Heute habe ich dann zufällig gemerkt, dass diese totale Systemüberlastung sogar auftritt, wenn ich mittels Alt+F2 unter KDE die Eingabezeile zum Schnellstart von Programmen einblende. Und die kann nun wirklich nicht viel Speicher fressen. Ein „top“ hat mir verraten, dass der Window Manager „kwin“ – zusätzlich zum VMWare Player – dann jede Menge CPU braucht. Und darüber bin ich drauf gekommen, wo das Problem liegen könnte.

Es sind die sogenannten „Arbeitsflächen-Effekte“! Also die Animationen beim Wechsel zwischen virtuellen Desktops, beim in den Vordergrund-Bringen von Fenstern etc. Und in der Tat, auf älteren Rechnern hatte ich die meist nicht aktiviert, deswegen hatte ich das Problem dort nicht.

Die gute Nachricht ist, man muss die nicht komplett deaktivieren, man kann sie mit der Tastenkombination Shift+Alt+F12 auch temporär deaktivieren bevor man VMWare startet. Und mit derselben Kombination wieder aktivieren, wenn VMWare beendet ist. Problem gelöst 🙂KDE Arbeitsflächen-Effekte

Advertisements

Ein Gedanke zu “Performanceproblem VMWare / Windows 7 / KDE (openSUSE 13.2) gelöst

  1. Kleiner Nachtrag: es scheint auch nochmal geholfen zu haben, den Drucker und das DVD Laufwerk in den Einstellungen der VM zu entfernen. Zumindest ist seitdem das sporadische Einfrieren der VM (teils für Minuten) nicht mehr aufgetreten.

    Gefällt mir

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s